| IFK | IRB | INFORLEX | GAZETA PRAWNA | INFORORGANIZER | APLIKACJA MOBILNA | PRACA W INFOR | SKLEP
reklama
Jesteś tutaj: STRONA GŁÓWNA > Moja firma > Biznes > Firma > e-Firma > Samouczek > Obliczanie średniej warunkowej w Excelu

Obliczanie średniej warunkowej w Excelu

Najlepszym przykładem ilustrującym zastosowanie średniej warunkowej jest podsumowanie sprzedaży przedstawicieli handlowych w danym okresie i na określonym terenie. Pierwszy zawiera dane odnośnie przedstawicieli , drugi zestawienie regionów. Jeśli zatem chcesz obliczyć średnią wartość sprzedaży użyj następującej formuły.

Zakładamy że adresy komórek (numery kolumn i wierszy są umowne) w swoim przypadku zastosuj odpowiednik z własnej tabeli.

=SUMA.JEŻELI(sprzedaż!$B$2:$B$19;średnia!B2;sprzedaż!$D$2:$D$19)/LICZ.JEŻELI(sprzedaż!$B$2:$B$19;średnia!B2)

SUMA.JEŻELI - od tej funkcji zależy sprawdzenie jak poszczególne wartości wpisane jako pierwszy argument mają się do równości z wartościami podanymi jako argument drugi. W W wypadku zgodności funkcja bierze do sumy odpowiednią wartość z zakresu trzeciego argumentu. Funkcja LICZ.JEŻELI liczy nam ilość komórek z zakresu pierwszego argumentu jest równych wartości argumentu drugiego.

Pamiętaj, ze poszczególne komórki podane w przykładzie musisz dostosować do swoich tabel.

Teraz zgodnie z powyższą formułą zaznaczamy C2 i wchodzimy w menu Edycja -> Kopiuj. Następnie zaznaczamy komórki od C3 do C6 i wybieramy polecenie Wklej z menu Edycja. Polecenia Kopiuj / Wklej możemy zastąpić w następujący sposób: po najechaniu myszką na komórkę C2 kierujemy kursor myszki na prawy dolny róg tej komórki i po pojawieniu się czarnego krzyżyka przeciągamy w dowolne miejsce.

Zobacz: Jak napisać regulamin sklepu internetowego

Od tego momentu kolumna C wyświetlać będzie średnią sprzedaż przedstawicieli dla określonego rejonu sprzedaży.

W Excelu 2007 dostępna jest jeszcze jedna, bardzo przydatna funkcja - ŚREDNIA.JEŻELI. Argumenty tej funkcji są dokładnie takie same jak w przypadku funkcji SUMA.JEŻELI. Aby jej użyć do komórki C2 wpisujemy poniższą formułę:

=ŚREDNIA.JEŻELI (sprzedaż!$B$2:$B$19;B2;sprzedaż!$D$2:$D$19)

Sprawdź: Corel Home Office

Pamiętaj jednak, że ta funkcja nie działa w poprzednich edycjach arkusza. 

Porady internetowe, newsy i ciekawostki - czytaj na internet.wieszjak.pl

reklama

Narzędzia przedsiębiorcy

POLECANE

Dotacje dla firm

reklama

Ostatnio na forum

Fundusze unijne

Pomysł na biznes

Eksperci portalu infor.pl

Anna Mrugas

ekspert z zakresu prawa pracy

Zostań ekspertem portalu Infor.pl »