| IFK | IRB | INFORLEX | GAZETA PRAWNA | INFORORGANIZER | APLIKACJA MOBILNA | PRACA W INFOR | SKLEP
reklama
Jesteś tutaj: STRONA GŁÓWNA > Moja firma > Biznes > Firma > e-Firma > Samouczek > Wybieranie określonej wartości tabeli (Excel)

Wybieranie określonej wartości tabeli (Excel)

Porada ta z pewnością przyda się wszystkim właścicielom firm. Zestawiając dwa arkusze, jeśli jeden zawiera dane z bazą kosztów poszczególnych działów w rozbiciu na miesiące. Drugi jako podsumowanie ma w dwóch komórkach odpowiednio nazwę działu i miesiąc. Zestawieni to ma na celu po uzupełnieniu dwóch komórek wyświetlenie razem wartości z komórek miesiąca i działu. Oto potrzebna do zbudowania takiego zestawienia funkcja.

Dla uproszczenia przyjmijmy, że korzystamy z komórek C2 i C3 oraz C5 w kolejnym arkuszu podsumowującym.

1. Komórkę C5 należy oznaczyć funkcją INDEKS oraz PODAJ.POZYCJĘ, która zwróci odpowiednią wartość. Formuła będzie w tym wypadku następująca:

=INDEKS(Dane!$B$2:$M$11;PODAJ.POZYCJĘ(C2;Dane

!$A$2:$A$11;0);PODAJ.POZYCJĘ(C3;Dane!$B$1:$M$1;0))

Czytaj: Ransomware - komputerowi szantażyści

1. Pierwszy argument funkcji INDEKS zawiera zakres komórek całej tabeli.

2. Drugi argument to funkcja PODAJ.POZYCJĘ, która wśród komórek zawierających nazwy działów firmy odnajdzie ten właściwy, który akurat chcemy podsumować.

3. Trzeci argument funkcji INDEKS szukamy w jakiej pozycji występuje nazwa miesiąca którą chcemy podsumować.

Sprawdź: Ukryte możliwości GPS

Formuła ta wydaję się skomplikowana, ale ma to swoje zalety. W przyszłości jeśli chcemy możemy bowiem do niej dodać kolejne kolumny, kolejne działy i miesiące.

Formuła zawarta w komórce C5 musi tylko zostać skopiowana do następnej komórki po jej prawej stronie (np. C6).

Pamiętajmy przy tym, że znak $ powoduje, że po skopiowaniu adres komórki nie ulega zmianie, w przeciwieństwie do adresów bez tego znaku.

Porady internetowe, newsy i ciekawostki - czytaj na internet.wieszjak.pl

reklama

Narzędzia przedsiębiorcy

POLECANE

Dotacje dla firm

reklama

Ostatnio na forum

Fundusze unijne

Pomysł na biznes

Eksperci portalu infor.pl

Artur Tim

Prawnik w Departamencie Doradztwa Podatkowego i Prawnego Kancelarii Mariański Group w Łodzi

Zostań ekspertem portalu Infor.pl »